Poster un commentaire à la suite de l’article...

samedi 1er juin 2002
par  Gaétan RYCKEBOER

Mettre sa linuxette à jour

Rapide tour d’horizon des utilitaires (sous Debian) pour mettre sa distribution à jour.

En réponse à...

Logo de asr
lundi 10 juin 2002 à 12h36 - par  asr

Si vous utilisez réguliÚrement Debian, vous pourrez avoir besoin de paquets disponibles dans une version plus récente que votre version stable ou testing actuelle.

Il est possible de récupérer ces paquets, sans toutefois mettre à jour toute sa distribution.

Pour ce faire, dans votre fichier /etc/apt/apt.conf, ajoutez :

APT::Default-Release "testing";

Et lors de l’installation d’un paquet, utilisez l’option "-t", comme dans l’exemple :

# apt-get -t unstable install <nom du paquet>

Bien évidemment, il faut avoir une "source" debian "unstable" ou "testing", pour avoir la liste des paquets.

Cette astuce précise simplement à apt-get de ne pas tenir compte des paquets qui seraient plus récents que les paquets de la branche définie par défaut dans le apt.conf.

ATTENTION il est dangereux de faire ce genre de manipulation, et cela doit être réservé à quelques cas trÚs précis, comme un php 4.2 (au lieu du 4.1 en potato), ou ce genre de choses. Si vous avez besoin de plus de 5 ou 6 paquets... passez en unstable avec tous lkes problÚmes que cela implique, ou passez vous en.

Forum sur abonnement

Pour participer à ce forum, vous devez vous enregistrer au préalable. Merci d’indiquer ci-dessous l’identifiant personnel qui vous a été fourni. Si vous n’êtes pas enregistré, vous devez vous inscrire.

Connexions’inscriremot de passe oublié ?

Agenda

<<

2022

 

<<

Juillet

 

Aujourd’hui

LuMaMeJeVeSaDi
    123
45678910
11121314151617
18192021222324
25262728293031

Annonces

Annuaire LibreNord

Retrouvez l’annuaire de logiciels libres créé par l’association Club Linux Nord-Pas de Calais sur le site suivant http://www.librenord.org